homebrew安装指定版本node

半兽人 发表于: 2020-01-04   最后更新时间: 2020-01-05  

mac环境下,使用homebrew 安装的node, 默认是最高版本,命令如下:

brew install node

最近在研究weex, 按照官网安装命令 npm install weex-toolkit -g, 会产生报错。后来发现在低版本node下安装就不会报错,比如当前node(v8.11.4LTS)版本.

那么使用homebrew如何安装指定版本的node呢?

  1. 如果之前使用brew install node安装过node,需要先执行brew unlink node来'解绑'node

  2. 查找可用的node版本 brew search node

  3. 安装你需要的版本, 比如 brew install node@8

  4. 然后 brew link node@8, 这一步可能会报错, 按照提示执行命令就ok了, 比如我最后执行的是brew link --overwrite --force node@8

  5. node -v 不出意外, 就安装好了你想要的node版本



您需要解锁本帖隐藏内容请: 点击这里
本帖隐藏的内容




上一条: 到头了!
下一条: 已经是最后了!