kafka能够将高版本的补丁改入当前版本自行编译实现bug修复吗?

宁静志远 发表于: 2019-07-10   最后更新时间: 2019-07-10  

当前使用kafka版本1.1.0,在使用过程中遇到了一些已经在高版本修复的bug:

KAFKA-6982
KAFKA-7165

因为担心升级会带来新的问题和bug,考虑能否将这些补丁改入当前版本,自行编译实现bug修复,不知是否可行,有了解的朋友给一些指导和意见。



您需要解锁本帖隐藏内容请: 点击这里
本帖隐藏的内容





发表于: 1月前   最后更新时间: 1月前   游览量:126
上一条: kafka消费不出来数据,不报错 poll无阻塞
下一条: Docker部署kafka创建主题后无对应文件/夹生成。

  • 可行呀,从源码进行打包

    • 大佬,高版本的patch加到低版本会不会引入什么其他的bug?以及有些错误完全没法复现,加了也不知道有没有修复成功,这个情况该咋办?
      另外,高版本的patch修改之前,那个文件可能有中间的其他commit修改了...对scale不太懂,不太敢直接改源码,还望前辈进一步指导。