kafka遇到一个异常 The group member's supported protocols are incompatible with those of existing members or first group member tried to j

季容 发表于: 2018-08-28   最后更新时间: 2018-08-28 21:25:16   6,855 游览

org.apache.kafka.common.errors.InconsistentGroupProtocolException: The group member's supported protocols are incompatible with those of existing members or first group member tried to join with empty protocol type or empty protocol list.

发表于 2018-08-28
添加评论

这个问题要怎么解决,是因为生产者和消费者版本jar包不一致导致的嘛

组成员支持的协议与现有成员的协议不兼容,或者第一组成员尝试使用空协议类型或空协议列表加入。
季容 -> 半兽人 5年前
那应该如何兼容?
半兽人 -> 季容 5年前
你检查下你的协议呀
冷面杀手 -> 半兽人 5年前
错误都提示的很明显了吧
周灿 -> 冷面杀手 5年前
怎么解决啊,求解答
周灿 -> 季容 5年前
解决了嘛,怎么解决的
周灿 -> 半兽人 5年前
什么协议,协议都是在jar包里面吧
你的答案

查看kafka相关的其他问题或提一个您自己的问题